Metro Exodus

Невозможно включить DirectX12

DefJimmy #
8
Всем привет! Решение данной проблемы уже найдено? В настройках игры переключение DirectX недоступно вообще. 11-й стоит по умолчанию, при этом сама опция заблокирована.
Догмит #
0
DefJimmy
какая видеокарта и винда?
DefJimmy #
0
Догмит
GTX 1080. Win 10 x64.
Догмит #
0
DefJimmy
Нужна самая последняя версия dx и винда со всеми последними обновлениями.
callmegod #
1
Догмит
А зачем обновления винды? 2 года назад винда была "последняя"? Или на 1607, 1709 - не было dx12?
Та же проблема. RX 480, Ryzen 5 1600, Win 10 1607. DirectX 12 в остальных играх распознается.
Догмит #
1
callmegod
а хрен его знает
KIBERMAX #
1
Скорее всего не включается Directx 12, из за того что игра как бы RTX типа поддерживает, и сглаживание dlss, и типа для игр с RTX поддержкой нужна windows 10 1809 как минимум, потому что в этой версии добавлена поддержка RTX, и скорее всего с играми с поддержкой Directx 12+RTX такие ограничения, и скорее это бред.

UPD. ну или же винда уже глюченая, и пора её переустановить на новую версию и обновить дрова.
callmegod #
1
У меня 1803 dx12 по-умолчанию включен в настройках игры.
lordkaho #
2
DefJimmy
Надо смотреть полную версию 10. Должна быть сборка 1809.
lordkaho #
4
callmegod
на сборках меньше 1809 игра DX12 не гарантирует из-за некоторых ошибок.
DefJimmy #
5
lordkaho
Уже всё решил! Обновил систему до актуальной версии и вуаля!)

Всем спасибо за помощь!
Dima_Fiate #
0
lordkaho
1709 сборка. Gtx 1066 могу спокойно включить dx 12. Причем даже игра сама его поставила.
Shepard70 #
1
1803 DX12 Стоит , полет нормальный Win1064 Pro
lordkaho #
1
Dima_Fiate
Это нормально, там штук 5 сборок, как минимум, нормально работает. Просто рекомендация от разработчиков, если сборка не 1809 то DX12 не гарантируется.
lordkaho #
1
Shepard70
1803, судя по отзывам тоже DX12 нормально держит. Есть ряд сборок которые глючат, так что самый простой совет - обновится до 1809.
lordkaho #
0
callmegod
Затем, что начиная с 8.1 микрософт отказалось от "лоскутной" сборки windows, то есть сейчас нет сервис-паков как раньше, а есть версионные сборки. Это позволяет не создавать монстров типа windows XP последних патчей, когда все латано-перелатано и отследить глюки очень сложно.
SergeyKorolev #
0
DefJimmy
Помню в батле 5, Ларе последней тоже нельзя было включить dx12 на винде LTSB 1607. И метро не исключение.
Вижу уже решил проблему.
Всё из-за лучей и привязки dx12 к ос теперь.
Clerick85 #
1
при переключении на 11ую вылетает на 12ой идёт
Xenol #
0
Clerick85
Такая же хрень. Винда 1809 дрова все последние.
Ar4er2016 #
0
Как вообще сейчас версия 1809, тоже хотел обновиться (сейчас версия 1607 LTSB), но слышал было много проблем в играх и в системе с этой версией?
X_ray_83 #
2
callmegod
Некоторые игры требуют обновления винды ! В Метро конкретно указана версия Win 10 1809 значит разрабы так "оптимизировали" !
Xenol #
1
Ar4er2016
Да все норм. Лично у меня летает как часики. Вот только я заново все сносил и ставил а не обновлялся.
Wundemar #
0
Аналогично стоит Win 10 старая сборка 1607-14393, в настройках только DX11.
www.microsoft.com/ru-ru/software-download/window..
Clerick85 #
0
прошел игру на минималках,сюжет норм но за 5 лет не могли оптимизировать
Wundemar #
0
Clerick85
Какие 5 лет? игру в конце разработки оптимизируют, если вообще оптимизируют.
Clerick85 #
0
эту игру разрабы делали 5 лет и не оптимизировали за такое время и она должна была выйти ещё 3 года назад
B
i
u
Спойлер