RAGE 2

Проблемы с разрешением экрана в Rage 2

snorkfear #
0
Приветствую! Подскажите пожалуйста как изменить разрешение экрана в Rage 2 не заходя в игру? Дело в том, что мой монитор имеет разрешение 1440*900, но моя долбаная видеокарта ставит по умолчанию 1920*1080, в итоге чёрный экран. Исправляю обычно в файлах конфига, но здесь этого файла не нашёл. Может есть ещё какие способы?
Din Printer #
3
snorkfear
Попробуй систему поставить на разрешение 1440*900.И в игре она автоматом будет такое же.В настройках системы или настройках нвидии если видеокарта от amd то не знаю чем помочь .
SonyK. #
3
snorkfear
Раньше у меня было подобное, потом стал использовать Custom Resolution Utility и всё стало нормально. Нужно выставить в программе своё разрешение и частоту обновления: в систему прописывается информация, что монитор на большее "не способнен" - в ОС (и играх) максимальным будет разрешение и частота, указаные в программе.
Спойлер



Видео начала игры, настройки после вступительного ролика (~2:40).
Спойлер

Din Printer написал:
Попробуй систему поставить на разрешение... в игре она автоматом будет такое же.

Не всегда помогает: некоторые игры упорно пытаются запускаться не только в более высоком разрешении (что некоторые мониторы ещё выдерживают), но и с повышенной частой (например 144 вместо 60 Гц) - обычно после этого чёрный экран с надписью о том, что такой режим монитором не поддерживается.
Iskandal #
1
snorkfear
C:\Users\Имя пользователя\Saved Games\id Software\Rage 2
Конфиг по этому пути находится. У самого такое же разрешение монитора и такакая же ерунда вылезла
snorkfear #
1
Iskandal
Туда тоже заглядывал, конфига не нашёл, только пустая папка.
Дед МастДай #
1
snorkfear
Вариант 1
При запуске игры нажать Alt+Enter, чтобы переключиться на оконный режим и потом в игре выставить своё разрешение.

Вариант 2
По пути C:\Users\Имя пользователя\Saved Games\id Software\Rage 2 должен быть файл конфигурации settings.ini и папка Saves.

Открываешь его текстовым редактором и находишь строки:

[Display]
Fullscreen=2
FullscreenWidth=1920
FullscreenHeight=1080
WindowedWidth=1280
WindowedHeight=720

Выставляешь своё разрешение или меняешь Fullscreen=2 (полноекранный), на Fullscreen=1 (в окне).

Игра создаёт файл конфига при первом запуске, если она ни разу не запускалась, то файла может и не быть. Тогда попробуй создать его сам.
snorkfear #
0
Дед МастДай
Спасибо большое! Создал файл, скопировал строчки. Помогло!
SergeyAl #
0
Дед МастДай
Привет! Нашел данный путь,в папке Rage создаю блокнот файл,копирую,вставляю,меняю все на свое. Но при запуске опять черный экран и надпись что монитор не поддерживает. Что то делаю не так? заранее спасибо.
Дед МастДай #
0
SergeyAl
Поставь в свойствах файла атрибут только для чтения.
SergeyAl #
0
Дед МастДай
не помогло(
Дед МастДай #
0
SergeyAl
SergeyAl написал:
Нашел данный путь,в папке Rage создаю

Папка называется Rage 2
Созданный в блокноте файл settings.txt нужно переименовать в settings.ini.
SergeyAl #
0
Дед МастДай
Rage 2,там создаю,не захожу в папку Saves. Создаю не settings.txt,а сразу settings.ini.
Кажется я косячу где то на этапе создания.

Дед МастДай #
0
SergeyAl
По идее всё должно работать, возможно проблема черного экрана не в разрешении. Попробуй запустить в оконном режиме.
SergeyAl #
0
Дед МастДай
В разрешение. При запуске гаснет монитор п плавающая надпись "input not supported". Запускаю именно в оконном режиме. Разрешение моника 1366х768. Черт,все перепробывал уже.
Дед МастДай #
0
SergeyAl
В параметрах папок и поиска должна быть отключена галочка в пункте - "скрывать расширения для зарегистрированных типов файлов". Если её не отключить, то при создании файла в блокноте, расширение ini после точки, будет записано в имя файла, а не в расширение. В результате получится sеttings.ini.txt вместо, settings.ini, так как расширение файла просто скрыто. Такой тип файла игра не увидит.
Спойлер
Проверь нет ли здесь ошибки.
"input not supported" может возникать не только из-за неподдерживаемого разрешения, но и из-за неподдерживаемой частоты монитора. Можно попробовать принудительно в драйверах включить вертикальную синхронизацию.
Так же попробуй в ini файле прописать не разрешение своего монитора (1366х768), а например 1280х720. Возможно такое разрешение не поддерживается самой игрой, и она при запуске сбрасывает конфиг на дефолт.
PS.
SergeyAl написал:
Запускаю именно в оконном режиме.

Тогда попробуй наоборот в полноэкранном. (в конфиг файле для оконного и полноэкранного режимов разные значения разрешения).
B
i
u
Спойлер