Баг в эмуляторе Xenia

Прохожу на эмуляторе Sonic The Hedgehog 2006. Данная игра в принципе на эмуляторе полностью проходима, это важно.
Но у меня возникает довольно странный баг: при появлении в кадре конкретного персонажа (не важно, катсцена или сам процесс игры) экран становится черным, но звук идет, причем, судя по тому, как он меняется при попытке поиграть, все работает, просто происходящее не отображается. При этом HUD и субтитры все еще видны, просто в крайне низком разрешении.
Спойлер


Пробовала ставить другую версию игры (английскую), но ничего не поменялось


Так же я заметила, что если встать в какие-то определенные места (либо ближе к границам уровня, либо вплотную к некоторым стенам) либо получить урон, то все на короткое время становится видно, но при этом экран очень часто моргает (все становится черным на доли секунд).
Спойлер

С трудом удалось поймать момент


Что это за странный баг такой и что делать? До этого в игре была только ошибка "Microsoft Visual C++ Runtime Library" при сохранениях. Вылечилось запуском xenia в режиме совместимости. Все остальное прекрасно работает.
Играю с Windows 7 и переходить с нее ни при каких обстоятельствах не буду.
Xerus13
Узконаправленные вопросы нужно задавать на специализированных форумах, эмуляторы консолей 6 поколения.
http://www.emu-land.net/forum/
Subaru MotorSports
Спасибо за совет!
Xerus13
И на том форуме никто ничего не посоветовал, может подождать новую версию эмулятора, меня смущает твоя любовь к Windows 7, ведь есть Windows 10 LTSB, в нём вырезано всё лишние.
Subaru MotorSports
Новые версии вряд-ли будут выходить, а если и будут, то неизвестно когда. Об этом сказано на официальном сайте. Да и, думаю, вряд ли это поможет, по идее все и сейчас должно работать. Как я писала, данная игра входит в список полностью проходимых на эмуляторе.
Я же говорю, что не буду переходить с семерки, тем более если речь идет о Win 10. Мне как-то доводилось пользоваться десяткой, и это настолько убого и неудобно, что мне аж вспоминать противно. И даже LTSB (специально почитала про нее) ситуацию не исправляет, она не убирает всё то, что мне не нравится в windows 10.
Может, раз никто не может мне помочь, дадите сейв? Соник и Сильвер пройдены на 100%, уровень, на котором застряла — Wave Ocean за Шедоу.
Недавно нашла информацию, что вроде как проблема возникает при рендере через Vulkan. Сейчас обновилась до Windows 10, использую Dx12. Потом проверю.
Кстати, как я поняла, проблему можно исправить с помощью Sonic '06 Mod Manager. В разделе патчей надо включить пункт Omega Blur Fix

Так же я дошла до момента с Омегой. Действительно, все работает.
Авторизуйтесь, чтобы принять участие в обсуждении.